shape1
shape2
shape3
shape4
shape7
shape8

Не могу запустить мод.


Статус
Закрыто для дальнейших ответов.

iPsTrange

Освоившийся
Пользователь
19.07.2014
137
45
0
Ребята выручайте.Не когда не сталкивался с такой проблемой.Мод из сампа,в сампе все работает.А тут и плагины обновлял(инклуды)-не помогает.Бд-врубил.

----------

Loaded log file: "server_log.txt".
----------
 



Спойлер
Код:
SA-MP Dedicated Server
----------------------
v0.3e, ©2005-2012 SA-MP Team

[21:18:22]
[21:18:22] Server Plugins
[21:18:22] --------------
[21:18:22] Loading plugin: mysql
[21:18:22]

> MySQL plugin R5 successfully loaded.

[21:18:22] Loaded.
[21:18:22] Loading plugin: streamer
[21:18:22]

*** Streamer Plugin v2.5.2 by Incognito loaded ***

[21:18:22] Loaded.
[21:18:22] Loading plugin: sscanf
[21:18:22]

[21:18:22] ===============================

[21:18:22] sscanf plugin loaded.

[21:18:22] Version: 2.8.1

[21:18:22] © 2012 Alex "Y_Less" Cole

[21:18:22] ===============================

[21:18:22] Loaded.
[21:18:22] Loading plugin: PointToPoint
[21:18:22] PointToPoint Plugin Loaded.
[21:18:22] Loaded.
[21:18:22] Loading plugin: sql
[21:18:22] >> SQL plugin v2.6 successfully loaded.
[21:18:22] + MySQL support is enabled.
[21:18:22] + PostgreSQL support is enabled.
[21:18:22] Loaded.
[21:18:22] Loading plugin: regex
[21:18:22]


[21:18:22] ______________________________________


[21:18:22] Regular Expression Plugin v0.2.1 loaded
[21:18:22] ______________________________________


[21:18:22] By: Fro © Copyright 2009-2011
[21:18:22] ______________________________________


[21:18:22] Loaded.
[21:18:22] Loaded 6 plugins.

[21:18:22]
[21:18:22] Filterscripts
[21:18:22] ---------------
[21:18:22] Loading filterscript 'yom_buttons.amx'...
[21:18:22] Loaded 1 filterscripts.

[21:18:22] Script[gamemodes/mode1.amx]: Run time error 19: "File or function is not found"
[21:18:22] Number of vehicle models: 0
 
Последнее редактирование модератором:

Kostyaev

Магистр
Пользователь
19.07.2014
1 123
274
0
24
Возможные причины данной проблемы:

1.  У вас может быть не скомпилирован мод.

Заходим в папку gamemodes, открываем .pwn файл и нажимаем в клавишу F5


2.  Мод не до конца скомпилировался, или amx. файл поврежден.
Проверяем размер amx. файла, если 0 кб, значит ошибка компиляции. Проблема в исходном коде, или ошибка запуска компилятора. Запускайте pawncc.exe от имени администратора.


3.  У вас нету в моде функции main.
Открываем мод и добавляем:
main()
{
print("Сервер запущен...");
}

4.  У вас не установлены программы Net Framework или Microsoft Visual C++ (или установлены, но старые версии).
Скачайте и установите эти программы.(очень часто бывает у многих)


5.  Не прописаны в server.cfg плагины (или прописаны не использующиеся плагины).
Открываем файл server.cfg и если у вас нету строки plugins, то добавляем в конце
plugins *имя плагина*
Если у вас стоит Linux то после имени плагина должно быть расширение  .so:
plugins *имя плагина.so*

6. Стоит pawn от другой версии CRMP.
 

 

iPsTrange

Освоившийся
Пользователь
19.07.2014
137
45
0
Денис,это не то,я уж не такой тупой.Просто мод не запускается.В сампе норм-в крмп не вай вай

 

iPsTrange

Освоившийся
Пользователь
19.07.2014
137
45
0
Проблемку решил :cool:

Тему можно под снос:)

 
Последнее редактирование модератором:
Статус
Закрыто для дальнейших ответов.